knt_isolate_generator 1.0.0 copy "knt_isolate_generator: ^1.0.0" to clipboard
knt_isolate_generator: ^1.0.0 copied to clipboard

knt_isolate generator is an Isolator generator using source_gen

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/appixi/knt_isolate was unreachable. Make sure that the website is reachable via HEAD requests.

Repository URL doesn't exist.

At the time of the analysis https://github.com/appixi/knt_isolate was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: knt_isolate_generator,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: knt_isolate_generator, knt_isolate_generator.kntIsolateBuilder.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

SDK issues found:

Package is not compatible with the Dart SDK.

Because:

  • knt_isolate_generator that depends on:
  • knt_isolate that depends on:
  • isolator that is a package requiring flutter.
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:knt_isolate_generator/knt_isolate_generator.dart that imports:
  • package:knt_isolate_generator/src/generator.dart that imports:
  • package:knt_isolate_generator/src/utils/helper.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:knt_isolate_generator/knt_isolate_generator.dart that imports:
  • package:knt_isolate_generator/src/generator.dart that imports:
  • package:knt_isolate_generator/src/utils/helper.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:knt_isolate_generator/knt_isolate_generator.dart that imports:
  • package:knt_isolate_generator/src/generator.dart that imports:
  • package:knt_isolate_generator/src/utils/helper.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: Using a colon as the separator before a default value is deprecated and will not be supported in language version 3.0 and later.

lib/src/utils/recase.dart:73:41

   ╷
73 │   String _getCamelCase({String separator: ''}) {
   │                                         ^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/utils/recase.dart

INFO: Using a colon as the separator before a default value is deprecated and will not be supported in language version 3.0 and later.

lib/src/utils/recase.dart:82:44

   ╷
82 │   String _getConstantCase({String separator: '_'}) {
   │                                            ^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/utils/recase.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^3.3.1 3.4.1 6.4.1
build ^2.2.1 2.3.1 2.4.1
build_runner ^2.1.8 2.2.0 2.4.9
built_collection ^5.1.1 5.1.1 5.1.1
code_builder ^4.1.0 4.10.0 4.10.0
dart_style ^2.2.2 2.2.3 2.3.6
knt_isolate ^1.0.0 1.0.0 1.0.0
source_gen ^1.2.1 1.2.2 1.5.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 38.0.0 67.0.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build_config - 1.1.1 1.1.1
build_daemon - 3.1.1 4.0.1
build_resolvers - 2.0.9 2.4.2
build_runner_core - 7.2.7+1 7.3.0
built_value - 8.9.2 8.9.2
checked_yaml - 2.0.3 2.0.3
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
frontend_server_client - 2.1.3 4.0.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
isolator - 2.0.3 2.0.8
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.14.0 1.14.0
mime - 1.0.5 1.0.5
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
shelf - 1.4.1 1.4.1
shelf_web_socket - 1.0.4 1.0.4
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.1 0.7.1
timing - 1.0.1 1.0.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 2.4.5
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.3.1` on analyzer does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.