knt_bloc 4.1.1 copy "knt_bloc: ^4.1.1" to clipboard
knt_bloc: ^4.1.1 copied to clipboard

A handy bloc base for future Appixi's apps

0
likes
110/ 140
pub points
22%
popularity

We analyzed this package 35 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/appixi/knt_bloc was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: knt_bloc,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

217 out of 297 API elements (73.1 %) have documentation comments.

Some symbols that are missing documentation: knt_bloc, knt_bloc.AddToPagingDataEvent.newData, knt_bloc.BaseApiBloc.convertedException, knt_bloc.BaseApiBloc.convertedIssue, knt_bloc.BaseBloc.convertedException.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:knt_bloc/knt_bloc.dart that imports:
  • package:knt_bloc/src/ui/paging_widget.dart that imports:
  • package:knt_bloc/src/bloc/blocs.dart that imports:
  • package:knt_bloc/src/utils/logger.dart that imports:
  • package:logger/logger.dart that imports:
  • package:logger/src/outputs/file_output_stub.dart that imports:
  • dart:io

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:knt_bloc/knt_bloc.dart that imports:
  • package:knt_bloc/src/ui/paging_widget.dart that imports:
  • package:knt_bloc/src/bloc/blocs.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:knt_bloc/knt_bloc.dart that imports:
  • package:knt_bloc/src/ui/paging_widget.dart that imports:
  • package:knt_bloc/src/bloc/blocs.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Windows`.

Because:

  • package:knt_bloc/knt_bloc.dart that imports:
  • package:knt_bloc/src/ui/paging_widget.dart that imports:
  • package:knt_bloc/src/bloc/blocs.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • package:knt_bloc/knt_bloc.dart that imports:
  • package:knt_bloc/src/ui/paging_widget.dart that imports:
  • package:knt_bloc/src/bloc/blocs.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: 'DioError' is deprecated and shouldn't be used. Use DioException instead. This will be removed in 6.0.0.

lib/src/bloc/blocs.dart:221:54

    ╷
221 │ /// Base handles network required events & specific [DioError]
    │                                                      ^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bloc/blocs.dart

INFO: 'DioError' is deprecated and shouldn't be used. Use DioException instead. This will be removed in 6.0.0.

lib/src/bloc/blocs.dart:225:22

    ╷
225 │     if (exception is DioError) {
    │                      ^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bloc/blocs.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.11.0 2.11.0 2.11.0
bloc ^8.1.2 8.1.4 8.1.4
bloc_concurrency ^0.2.2 0.2.5 0.2.5
connectivity_plus ^4.0.1 4.0.2 6.0.2
dio ^5.1.2 5.4.3+1 5.4.3+1
flutter flutter 0.0.0 0.0.0
flutter_bloc ^8.1.3 8.1.5 8.1.5
logger ^1.3.0 1.4.0 2.2.0
meta ^1.9.1 1.11.0 1.14.0
scroll_to_index ^3.0.1 3.0.1 3.0.1
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
connectivity_plus_platform_interface - 1.2.4 2.0.0
dbus - 0.7.10 0.7.10
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.11.1
nested - 1.0.0 1.0.0
nm - 0.5.0 0.5.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.1` on connectivity_plus does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

The constraint `^1.3.0` on logger does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.