klutter 3.0.2 copy "klutter: ^3.0.2" to clipboard
klutter: ^3.0.2 copied to clipboard

Write Flutter plugins for both Android and iOS using Kotlin only.

52
likes
140/ 140
pub points
38%
popularity

We analyzed this package 11 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

262 out of 266 API elements (98.5 %) have documentation comments.

Some symbols that are missing documentation: consumer, gradle, producer, tasks.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:klutter/klutter.dart that imports:
  • package:klutter/src/producer/producer.dart that imports:
  • package:klutter/src/producer/project.dart that imports:
  • package:klutter/src/common/utilities.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dart_style ^2.2.4 2.3.6 2.3.6
interact ^2.2.0 2.2.0 2.2.0
meta ^1.9.1 1.15.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 68.0.0 68.0.0
_macros - 0.1.0 0.1.0
analyzer - 6.5.0 6.5.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_console - 1.2.0 4.1.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
intl - 0.18.1 0.19.0
macros - 0.1.0-main.0 0.1.0-main.5
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tint - 2.0.1 2.0.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
win32 - 5.5.1 5.5.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

52
likes
140
pub points
38%
popularity

Publisher

verified publisherbuijs.dev

Write Flutter plugins for both Android and iOS using Kotlin only.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dart_style, interact, meta

More

Packages that depend on klutter