kinfolk 1.0.1
kinfolk: ^1.0.1

Flutter Android iOS

A new Flutter package for integration with CUBA Platform based backend.

3
likes
70 / 110
pub points
40 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 150 API elements (8.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:kinfolk/kinfolk.dart that imports:
  • package:hive_flutter/hive_flutter.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Unused import: 'dart:io'.

lib/kinfolk.dart:3:8

  ╷
3 │ import 'dart:io';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/kinfolk.dart

lib/global_variables.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
hive^1.4.1+11.4.4+11.4.4+1
hive_flutter^0.3.0+20.3.10.3.1
oauth2^1.5.01.6.31.6.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.1.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
ffi-0.1.30.1.3
file-5.2.15.2.1
http-0.12.20.12.2
http_parser-3.1.43.1.4
intl-0.16.10.16.1
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.7.0
path_provider-1.6.241.6.24
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+60.0.4+6
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
70
pub points
40%
popularity

A new Flutter package for integration with CUBA Platform based backend.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

maihanov96@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, hive, hive_flutter, oauth2

More

Packages that depend on kinfolk