kanji_drawing_animation 0.5.0+1 copy "kanji_drawing_animation: ^0.5.0+1" to clipboard
kanji_drawing_animation: ^0.5.0+1 copied to clipboard

A widget that draws Kanji with the right stroke order based on KanjiVG.

14
likes
130/ 140
pub points
53%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 7 API elements (28.6 %) have documentation comments.

Some symbols that are missing documentation: kanji_drawing_animation.KanjiDrawingAnimation, kanji_drawing_animation.KanjiDrawingAnimation.KanjiDrawingAnimation, kanji_drawing_animation.KanjiDrawingAnimation.curve, kanji_drawing_animation.KanjiDrawingAnimation.kanji, kanji_drawing_animation.KanjiDrawingAnimation.speed.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:kanji_drawing_animation/kanji_drawing_animation.dart that imports:
  • package:kanji_drawing_animation/src/kanji_drawing_animation.dart that imports:
  • package:svg_drawing_animation/svg_drawing_animation.dart that imports:
  • package:svg_drawing_animation/src/svg_provider.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
svg_drawing_animation ^0.10.3 0.10.3+2 0.11.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_svg - 1.1.6 2.0.10+1
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
path_drawing - 1.0.1 1.0.1
path_parsing - 1.0.1 1.0.1
petitparser - 6.0.2 6.0.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.10.3` on svg_drawing_animation does not support the stable version `0.11.0`.

Try running dart pub upgrade --major-versions svg_drawing_animation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

14
likes
130
pub points
53%
popularity

Publisher

verified publisherwafrat.com

A widget that draws Kanji with the right stroke order based on KanjiVG.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, svg_drawing_animation

More

Packages that depend on kanji_drawing_animation