large Flutter Favorite logosmall Flutter Favorite logo

just_audio 0.9.29 icon indicating copy to clipboard operation
just_audio: ^0.9.29 copied to clipboard

A feature-rich audio player for Flutter. Loop, clip and concatenate any sound from any source (asset/file/URL/stream) in a variety of audio formats with gapless playback.

2281
likes
130/ 140
pub points
99%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected licenses: Apache-2.0, MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 219 out of 303 API elements (72.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:just_audio/just_audio.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:just_audio/just_audio.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Web`.

Because:

  • package:just_audio/just_audio.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'hashValues' is deprecated and shouldn't be used. Use Object.hash() instead. This feature was deprecated in v3.1.0-0.0.pre.897.

lib/just_audio.dart:1569:23

     ╷
1569 │   int get hashCode => hashValues(
     │                       ^^^^^^^^^^
     ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/just_audio.dart

INFO: 'hashValues' is deprecated and shouldn't be used. Use Object.hash() instead. This feature was deprecated in v3.1.0-0.0.pre.897.

lib/just_audio.dart:1634:23

     ╷
1634 │   int get hashCode => hashValues(playing, processingState);
     │                       ^^^^^^^^^^
     ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/just_audio.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.5.02.9.02.9.0
audio_session^0.1.100.1.100.1.10
crypto^3.0.03.0.23.0.2
flutterflutter0.0.00.0.0
just_audio_platform_interface^4.2.04.2.04.2.0
just_audio_web^0.4.70.4.70.4.7
meta^1.3.01.8.01.8.0
path^1.8.01.8.21.8.2
path_provider^2.0.02.0.112.0.11
rxdart>=0.26.0 <0.28.00.27.50.27.5
uuid^3.0.13.0.63.0.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.16.01.16.0
ffi-2.0.12.0.1
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
js-0.6.40.6.4
material_color_utilities-0.1.50.2.0
path_provider_android-2.0.202.0.20
path_provider_ios-2.0.112.0.11
path_provider_linux-2.1.72.1.7
path_provider_macos-2.0.62.0.6
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
process-4.2.44.2.4
sky_engine-0.0.990.0.99
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4
win32-3.0.03.0.0
xdg_directories-0.2.0+20.2.0+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.18, Flutter 3.3.3, Dart 2.18.2.

2281
likes
130
pub points
99%
popularity

Publisher

verified publisher iconryanheise.com

A feature-rich audio player for Flutter. Loop, clip and concatenate any sound from any source (asset/file/URL/stream) in a variety of audio formats with gapless playback.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.Apache-2.0, MIT (LICENSE)

Dependencies

async, audio_session, crypto, flutter, just_audio_platform_interface, just_audio_web, meta, path, path_provider, rxdart, uuid

More

Packages that depend on just_audio