json_schema 2.2.1
json_schema: ^2.2.1 copied to clipboard

Provide support for validating instances against json schema

8
likes
80 / 110
pub points
81 %
popularity

We analyzed this package on Apr 19, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 84 out of 140 API elements (60.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 149 issues. Showing the first 2:

INFO: Unnecessary new keyword.

bin/gensamples.dart:51:3

   ╷
51 │   new Directory(sourcePath).listSync().forEach((jsonFile) {
   │   ^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/gensamples.dart

INFO: 'refMap' is deprecated and shouldn't be used. Note: This information is useful for drawing dependency graphs, etc, but should not be used for general\nvalidation or traversal. Use [endPath] to get the absolute [String] path and [resolvePath]\nto get the [JsonSchema] at any path, instead.\n\nThis functionality will be removed in 3.0.\n .

bin/gensamples.dart:58:14

   ╷
58 │       schema.refMap.forEach((key, ref) => print('$key : $ref'));
   │              ^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/gensamples.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args>=0.13.7 <2.0.01.6.02.0.0
collection^1.14.61.15.01.15.0
dart2_constant^1.0.01.0.2+dart21.0.2+dart2
logging>=0.9.3 <0.12.00.11.41.0.1
path^1.3.01.8.01.8.0
uri>=0.11.1 <0.12.00.11.41.0.0
w_transport^3.2.83.2.83.2.8
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
charcode-1.2.01.2.0
cli_repl-0.2.20.2.2
clock-1.1.01.1.0
colorize-2.0.03.0.0
file-5.2.16.1.0
fluri-1.3.02.0.0
glob-1.2.02.0.1
http-0.12.20.13.1
http_parser-3.1.44.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-0.9.71.0.0
node_interop-1.2.12.0.0
node_io-1.2.01.2.0
package_config-1.9.32.0.0
package_resolver-1.0.101.0.10
pedantic-1.11.01.11.0
quiver-2.1.53.0.1
sass-1.32.81.32.11
sockjs_client-0.3.50.3.5
sockjs_client_wrapper-1.1.01.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.32.0.0
typed_data-1.3.01.3.0
w_common-1.20.41.20.4
watcher-0.9.7+151.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=0.13.7 <2.0.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `>=0.9.3 <0.12.0` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

8
likes
80
pub points
81%
popularity

Publisher

workiva.com

Provide support for validating instances against json schema

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, collection, dart2_constant, logging, path, uri, w_transport

More

Packages that depend on json_schema