jalali_calendar 1.0.4 copy "jalali_calendar: ^1.0.4" to clipboard
jalali_calendar: ^1.0.4 copied to clipboard

Calendar , Datepicker and Date Convertor For Persian Date(Jalali/Shamsi date) with holiday

70
likes
80/ 160
pub points
71%
popularity

We analyzed this package 3 days ago, and awarded it 80 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

31 out of 99 API elements (31.3 %) have documentation comments.

Some symbols that are missing documentation: persian_date, persian_date.AM, persian_date.D, persian_date.DD, persian_date.DateChangedCallback.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 112 issues. Showing the first 2:

ERROR: The method 'FlatButton' isn't defined for the type '_DatePickerState'.

lib/src/datepicker.dart:495:20

    ╷
495 │             child: FlatButton(
    │                    ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/datepicker.dart

ERROR: The method 'FlatButton' isn't defined for the type '_DatePickerState'.

lib/src/datepicker.dart:502:20

    ╷
502 │             child: FlatButton(
    │                    ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/datepicker.dart

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
jiffy ^4.1.0 4.1.0 6.3.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
intl - 0.17.0 0.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.1.0` on jiffy does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions jiffy to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 19 errors:

  • UNDEFINED_METHOD - lib/src/datepicker.dart:495:20 - The method 'FlatButton' isn't defined for the type '_DatePickerState'.
  • UNDEFINED_METHOD - lib/src/datepicker.dart:502:20 - The method 'FlatButton' isn't defined for the type '_DatePickerState'.
  • UNDEFINED_GETTER - lib/src/jalalicalendarpicker.dart:78:23 - The getter 'primaryColorBrightness' isn't defined for the type 'ThemeData'.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

70
likes
80
pub points
71%
popularity

Publisher

verified publisherflutterfarsi.ir

Calendar , Datepicker and Date Convertor For Persian Date(Jalali/Shamsi date) with holiday

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

flutter, jiffy

More

Packages that depend on jalali_calendar