isar_flutter_libs 4.0.0-dev.14 copy "isar_flutter_libs: ^4.0.0-dev.14" to clipboard
isar_flutter_libs: ^4.0.0-dev.14 copied to clipboard

Isar Core binaries for the Isar Database. Needs to be included for Flutter apps.

36
likes
140/ 160
pub points
99%
popularity

We analyzed this package 6 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 1 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: isar_flutter_libs.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
isar 4.0.0-dev.14 4.0.0-dev.14 4.0.0-dev.14
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 73.0.0
analyzer - 6.4.1 6.8.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
build - 2.4.1 2.4.1
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
js - 0.6.7 0.7.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
sky_engine - 0.0.99 0.0.99
source_gen - 1.5.0 1.5.0
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

36
likes
140
pub points
99%
popularity

Publisher

verified publisherisar.dev

Isar Core binaries for the Isar Database. Needs to be included for Flutter apps.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (license)

Dependencies

flutter, isar

More

Packages that depend on isar_flutter_libs