iqplayer 0.4.1
iqplayer: ^0.4.1 copied to clipboard

Simple awesome video player with subtitle (you can load from assets, file, network, string).

27
likes
100/ 130
pub points
74%
popularity

We analyzed this package on Oct 25, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 42 API elements (45.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:iqplayer/iqplayer.dart that imports:
  • package:video_player/video_player.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/ui/screen_controllers.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc>=7.0.0 <8.0.07.2.17.2.1
equatable>=2.0.0 <2.1.02.0.32.0.3
flutterflutter0.0.00.0.0
flutter_bloc>=7.0.0 <8.0.07.3.17.3.1
http>=0.13.3 <0.14.00.13.40.13.4
simple_html_css>=3.0.1 <3.1.03.0.1+13.0.1+1
video_player>=2.1.1 <2.2.02.1.152.2.5
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.2
boolean_selector-2.1.02.1.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
fake_async-1.2.01.2.0
flutter_web_plugins-0.0.00.0.0
html_unescape-2.0.02.0.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
matcher-0.12.100.12.11
meta-1.7.01.7.0
nested-1.0.01.0.0
path-1.8.01.8.0
petitparser-4.4.04.4.0
provider-6.0.16.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.4.20.4.6
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
video_player_platform_interface-4.2.04.2.0
video_player_web-2.0.42.0.4
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.1.1 <2.2.0` on video_player does not support the stable version `2.2.0`.

Try running dart pub upgrade --major-versions video_player to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

27
likes
100
pub points
74%
popularity

Publisher

iqds.club

Simple awesome video player with subtitle (you can load from assets, file, network, string).

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bloc, equatable, flutter, flutter_bloc, http, simple_html_css, video_player

More

Packages that depend on iqplayer