iop_sdk 5.0.0 icon indicating copy to clipboard operation
iop_sdk: ^5.0.0 copied to clipboard

SDK for Decentralized Access Control based on W3C standards to provide SSI with decentralized identifiers (DID), keys, rights and verifiable claims/credentials (VC).

1
likes
100/ 140
pub points
0%
popularity

We analyzed this package 3 hours ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://iop.global was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: LGPL-3.0.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 875 API elements (0.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:iop_sdk/authority.dart that imports:
  • package:iop_sdk/src/entities/authority/private_api.dart that imports:
  • package:iop_sdk/ssi.dart that imports:
  • package:iop_sdk/src/ssi/io.dart that imports:
  • package:iop_sdk/crypto.dart that imports:
  • package:iop_sdk/src/crypto/vault.dart that imports:
  • package:iop_sdk/src/ffi/ffi.dart that imports:
  • package:ffi/ffi.dart that imports:
  • package:ffi/src/utf16.dart that imports:
  • dart:ffi
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 459 issues. Showing the first 2:

INFO: The variable name 'secp_id' isn't a lowerCamelCase identifier.

lib/src/crypto/multicipher.dart:19:35

   ╷
19 │   static KeyId fromSecp(SecpKeyId secp_id) {
   │                                   ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/crypto/multicipher.dart

INFO: The variable name 'secp_pk' isn't a lowerCamelCase identifier.

lib/src/crypto/multicipher.dart:125:43

    ╷
125 │   static PublicKey fromSecp(SecpPublicKey secp_pk) {
    │                                           ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/crypto/multicipher.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^1.0.01.2.12.0.1
http^0.13.00.13.50.13.5
json_annotation^4.0.04.1.04.8.0
json_serializable^5.0.05.0.26.6.1
meta^1.1.81.9.01.9.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-31.0.052.0.0
analyzer-2.8.05.4.0
args-2.3.22.3.2
async-2.10.02.10.0
build-2.3.12.3.1
build_config-1.0.01.1.1
checked_yaml-2.0.12.0.2
cli_util-0.3.50.3.5
collection-1.17.11.17.1
convert-3.1.13.1.1
crypto-3.0.23.0.2
dart_style-2.2.12.2.4
file-6.1.46.1.4
glob-2.1.12.1.1
http_parser-4.0.24.0.2
logging-1.1.11.1.1
package_config-2.1.02.1.0
path-1.8.31.8.3
pub_semver-2.1.32.1.3
pubspec_parse-1.1.01.2.1
source_gen-1.2.21.2.7
source_helper-1.3.21.3.3
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on ffi does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

The constraint `^5.0.0` on json_serializable does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions json_serializable to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.1.

1
likes
100
pub points
0%
popularity

Publisher

verified publisher iconiop.global

SDK for Decentralized Access Control based on W3C standards to provide SSI with decentralized identifiers (DID), keys, rights and verifiable claims/credentials (VC).

Repository (GitHub)

Documentation

Documentation
API reference

License

Icon for licenses.LGPL-3.0 (LICENSE)

Dependencies

ffi, http, json_annotation, json_serializable, meta

More

Packages that depend on iop_sdk