internet_file 1.2.0 copy "internet_file: ^1.2.0" to clipboard
internet_file: ^1.2.0 copied to clipboard

A internet file getter (also optional downloader) that works in all platforms

140/ 160
pub points

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid

5/5 points: Provide a valid

10/10 points: Use an OSI-approved license

Detected license: MIT.

Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 17 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: internet_file, internet_file.InternetFile, internet_file.InternetFile.InternetFile, internet_file.InternetFile.get, internet_file.InternetFileProcess.

10/10 points: Package has an example

Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http ^0.13.4 0.13.6 1.2.1
path ^1.8.1 1.9.0 1.9.0
universal_file ^1.0.0 1.0.0 1.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
http_parser - 4.1.0 4.1.0
meta - 1.15.0 1.15.0
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

pub points



A internet file getter (also optional downloader) that works in all platforms

Repository (GitHub)
View/report issues


API reference


MIT (license)


http, path, universal_file


Packages that depend on internet_file