intercom_flutter 7.6.3+1 icon indicating copy to clipboard operation
intercom_flutter: ^7.6.3+1 copied to clipboard

Flutter plugin for Intercom integration. Provides in-app messaging and help-center Intercom services

94
likes
140/ 140
pub points
96%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 27 out of 29 API elements (93.1 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:intercom_flutter/intercom_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:intercom_flutter/intercom_flutter.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:intercom_flutter/intercom_flutter.dart that declares support for platforms: Android, iOS, Web.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_web_pluginsflutter0.0.00.0.0
intercom_flutter_platform_interface^1.2.21.2.21.2.2
intercom_flutter_web^0.2.20.2.20.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
crypto-3.0.23.0.2
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
typed_data-1.3.11.3.1
uuid-3.0.73.0.7
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

94
likes
140
pub points
96%
popularity

Publisher

verified publisher iconintercom.deepakdroid.xyz

Flutter plugin for Intercom integration. Provides in-app messaging and help-center Intercom services

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, flutter_web_plugins, intercom_flutter_platform_interface, intercom_flutter_web

More

Packages that depend on intercom_flutter