imou_plugin 0.0.1 copy "imou_plugin: ^0.0.1" to clipboard
imou_plugin: ^0.0.1 copied to clipboard

A plugin to show imou camera view in flutter app

0
likes
110/ 160
pub points
0%
popularity

We analyzed this package 5 hours ago, and awarded it 110 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: imou_plugin,
    • contains a version property, and,
    • does not contain a publish_to property.

pubspec.yaml from the repository has no repository or homepage URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

14 out of 76 API elements (18.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: access_token_response, access_token_response.AccessTokenResponse, access_token_response.AccessTokenResponse.AccessTokenResponse, access_token_response.AccessTokenResponse.AccessTokenResponse.fromJson, access_token_response.AccessTokenResponse.id.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:imou_plugin/imou_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:imou_plugin/imou_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:imou_plugin/imou_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:imou_plugin/imou_plugin.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

WARNING: The value of the field '_eventChannel' isn't used.

lib/controller/camera_controller.dart:14:21

   ╷
14 │   late EventChannel _eventChannel;
   │                     ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/controller/camera_controller.dart

WARNING: The value of the field '_cameraEventNotifier' isn't used.

lib/controller/camera_controller.dart:16:29

   ╷
16 │   ValueSetter<CameraEvent>? _cameraEventNotifier;
   │                             ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/controller/camera_controller.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
crypto ^3.0.3 3.0.3 3.0.3
dio ^4.0.6 4.0.6 5.5.0+1
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
uuid ^4.2.1 4.4.2 4.4.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
fixnum - 1.1.0 1.1.0
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.6` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.