imgly_sdk 3.1.0 copy "imgly_sdk: ^3.1.0" to clipboard
imgly_sdk: ^3.1.0 copied to clipboard

The official base plugin for the photo_editor_sdk and video_editor_sdk Flutter plugins.

11
likes
130/ 140
pub points
77%
popularity

We analyzed this package 36 hours ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

375 out of 376 API elements (99.7 %) have documentation comments.

Some symbols that are missing documentation: imgly_sdk.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:imgly_sdk/imgly_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:imgly_sdk/imgly_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:imgly_sdk/imgly_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:imgly_sdk/imgly_sdk.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

11
likes
130
pub points
77%
popularity

Publisher

verified publisherimg.ly

The official base plugin for the photo_editor_sdk and video_editor_sdk Flutter plugins.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on imgly_sdk