image_pick 0.0.3+4
image_pick: ^0.0.3+4 copied to clipboard

Image picker using image_picker and custom camera

2
likes
60/ 130
pub points
48%
popularity

We analyzed this package on Nov 25, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 79 API elements (6.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:image_pick/image_pick.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

lib/core/cyblock/camera/camera_cyblock.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/core/cyblock/camera/camera_event.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
camera^0.5.8+110.5.8+170.9.4+5
cyblock^0.0.1+40.0.1+40.0.1+4
flutterflutter0.0.00.0.0
fluttertoast>=7.0.1+1 <8.0.78.0.68.0.8
image^2.1.192.1.193.0.8
image_picker^0.6.7+140.6.7+220.8.4+4
path_provider^1.6.241.6.282.0.7
shared_preferences^0.5.12+40.5.12+42.0.9
system_info^0.1.30.1.31.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.6
args-1.6.02.3.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
cupertino_icons-1.0.41.0.4
ffi-1.1.21.1.2
file-6.1.26.1.2
file_utils-0.1.41.0.1
flutter_plugin_android_lifecycle-1.0.112.0.5
flutter_web_plugins-0.0.00.0.0
globbing-0.3.11.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
image_picker_platform_interface-1.1.62.4.1
js-0.6.30.6.3
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.1.2
path_provider_macos-0.0.4+82.0.3
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
pedantic-1.11.11.11.1
petitparser-3.1.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
shared_preferences_linux-0.0.2+42.0.3
shared_preferences_macos-0.0.1+112.0.2
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.2
shared_preferences_windows-0.0.2+32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.1.20.2.0
xml-4.5.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^0.5.8+11` on camera does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions camera to update the constraint.

The constraint `>=7.0.1+1 <8.0.7` on fluttertoast does not support the stable version `8.0.7`.

Try running dart pub upgrade --major-versions fluttertoast to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.