image_editor_pro_ander 1.0.3
image_editor_pro_ander: ^1.0.3 copied to clipboard

Image Editor Plugin with simple, easy support for image editing using paints,text and emoji like stories.

3
likes
100/ 130
pub points
56%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 31 out of 110 API elements (28.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:image_editor_pro_ander/image_editor_pro_ander.dart that declares support for platforms: Android, iOS, Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
cupertino_icons^1.0.21.0.41.0.4
dio^4.0.04.0.44.0.4
firexcode^1.0.51.0.81.0.8
flutterflutter0.0.00.0.0
flutter_colorpicker^0.4.00.4.01.0.2
flutter_web_pluginsflutter0.0.00.0.0
font_awesome_flutter^9.0.09.2.09.2.0
image_picker^0.7.40.7.5+40.8.4+4
path_provider^2.0.12.0.72.0.7
permission_handler^7.0.07.2.08.3.0
screenshot^0.3.00.3.01.2.3
signature^4.0.24.1.14.1.1
zoom_widget^0.1.30.1.30.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.031.0.0
analyzer-1.7.22.8.0
animated_interpolation-0.3.20.3.2
archive-3.1.63.1.6
args-2.3.02.3.0
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
console_cmd-1.0.51.0.5
convert-3.0.13.0.1
cross_file-0.3.20.3.2
crypto-3.0.13.0.1
dart_style-2.1.12.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_plugin_android_lifecycle-2.0.52.0.5
glob-2.0.22.0.2
grapheme_splitter-1.0.01.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
image-3.1.03.1.0
image_picker_for_web-2.1.42.1.4
image_picker_platform_interface-2.4.12.4.1
js-0.6.30.6.3
json_ast-1.0.51.0.5
meta-1.7.01.7.0
package_config-2.0.22.0.2
path-1.8.01.8.0
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
permission_handler_platform_interface-3.7.03.7.0
petitparser-4.4.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
process_run-0.12.2+20.12.2+2
pub_semver-2.1.02.1.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
watcher-1.0.11.0.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.4.0` on flutter_colorpicker does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions flutter_colorpicker to update the constraint.

The constraint `^0.7.4` on image_picker does not support the stable version `0.8.0`.

Try running dart pub upgrade --major-versions image_picker to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.