identity_firebase_link 0.3.0 icon indicating copy to clipboard operation
identity_firebase_link: ^0.3.0 copied to clipboard

Authenticate using Email Link by Firebase for Identity package

0
likes
70/ 130
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 13 API elements (15.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:identity_firebase_link/identity_firebase_link.dart that imports:
  • package:identity_firebase_link/src/firebase_email_link_authenticator.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:identity_firebase_link/identity_firebase_link.dart that imports:
  • package:identity_firebase_link/src/firebase_email_link_authenticator.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:identity_firebase_link/identity_firebase_link.dart that imports:
  • package:identity_firebase_link/src/firebase_email_link_authenticator.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:identity_firebase_link/identity_firebase_link.dart that imports:
  • package:identity_firebase_link/src/firebase_email_link_authenticator.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:identity_firebase_link/identity_firebase_link.dart that imports:
  • package:identity_firebase_link/src/firebase_email_link_authenticator.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:identity_firebase_link/identity_firebase_link.dart that imports:
  • package:identity_firebase_link/src/firebase_email_link_authenticator.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'RaisedButton' is deprecated and shouldn't be used. Use ElevatedButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.26.0-18.0.pre..

lib/src/email_link_page.dart:104:24

    ╷
104 │                 child: RaisedButton(
    │                        ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/email_link_page.dart

INFO: 'RaisedButton.RaisedButton' is deprecated and shouldn't be used. Use ElevatedButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.26.0-18.0.pre..

lib/src/email_link_page.dart:104:24

    ╷
104 │                 child: RaisedButton(
    │                        ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/email_link_page.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.1.32.1.53.0.2
firebase_auth^0.15.30.15.5+33.3.20
firebase_dynamic_links^0.3.00.3.04.2.6
flutterflutter0.0.00.0.0
identity^0.3.00.3.60.3.6
identity_firebase^0.3.00.3.00.3.0
shared_preferences^0.5.60.5.12+42.0.15
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
charcode-1.3.11.3.1
collection-1.16.01.16.0
convert-2.1.13.0.2
emitter-1.2.01.2.0
ffi-1.2.12.0.1
file-6.1.26.1.2
firebase-7.3.39.0.3
firebase_auth_platform_interface-1.1.86.2.8
firebase_auth_web-0.1.3+13.3.17
firebase_core-0.4.51.18.0
firebase_core_platform_interface-1.0.44.4.1
firebase_core_web-0.1.1+21.6.5
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.1
js-0.6.40.6.4
matcher-0.12.120.12.12
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
path-1.8.21.8.2
path_provider_linux-0.0.1+22.1.7
path_provider_platform_interface-1.0.42.0.4
path_provider_windows-0.0.52.1.0
pedantic-1.11.11.11.1
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.2
process-4.2.44.2.4
quiver-2.1.53.1.0
shared_preferences_linux-0.0.2+42.1.1
shared_preferences_macos-0.0.1+112.0.4
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.4
shared_preferences_windows-0.0.2+32.1.1
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2
win32-2.6.12.7.0
xdg_directories-0.1.20.2.0+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.1.3` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^0.15.3` on firebase_auth does not support the stable version `0.16.0`.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.

0
likes
70
pub points
0%
popularity

Publisher

unverified uploader

Authenticate using Email Link by Firebase for Identity package

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-2-Clause (LICENSE)

Dependencies

crypto, firebase_auth, firebase_dynamic_links, flutter, identity, identity_firebase, shared_preferences

More

Packages that depend on identity_firebase_link