identity_firebase 0.2.2

  • Readme
  • Changelog
  • Installing
  • 71

dart-identity-firebase #

Firebase Provider for identity package

0.2.2 #

  • Upgrade identity: ^0.2.2

0.2.0+1 #

  • Add ability to change theme, header's image in init

0.2.0 #

  • Upgrade identity: ^0.2.0

0.1.1 #

  • Implicitly use notify

0.1.0 #

  • Upgrade sso, identity packages

0.0.7 #

  • Override notify

0.0.6 #

  • Add Sign In With Phone
  • Change name of EmailAuthenticator to FirebaseEmailAuthenticator
  • Default is no authenticators loaded

0.0.5 #

  • Fix token exchange

0.0.4 #

  • Fix is_verified value

0.0.3 #

  • Improve sign in with email

0.0.2 #

  • Change helper getUser to static method convert of FirebaseProvider
  • Change file name

0.0.1 #

  • Implement Provider for Firebase
  • Implement EmailAuthenticator

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  identity_firebase: ^0.2.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:identity_firebase/identity_firebase.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
55
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Feb 28, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.8

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and identity_firebase.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
firebase_auth ^0.15.3 0.15.5+2
flutter 0.0.0
identity ^0.2.0 0.2.2
sso ^0.2.0 0.2.0
Transitive dependencies
async 2.4.0
charcode 1.1.3
collection 1.14.11 1.14.12
firebase 7.2.1
firebase_auth_platform_interface 1.1.7
firebase_auth_web 0.1.2
firebase_core 0.4.4+2
firebase_core_platform_interface 1.0.4
firebase_core_web 0.1.1+2
flutter_web_plugins 0.0.0
http 0.12.0+4
http_parser 3.1.3
js 0.6.1+1
matcher 0.12.6
meta 1.1.8
path 1.6.4
pedantic 1.9.0
plugin_platform_interface 1.0.2
quiver 2.1.2+1
sky_engine 0.0.99
source_span 1.6.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test