identity_firebase_link 0.2.2

  • Readme
  • Changelog
  • Installing
  • 46

dart-identity-firebase-link #

Authenticate using Email Link by Firebase for Identity package

Getting Started #

  1. Enable Sign In With Link in Authentication settings of Firebase's project
  2. Create a dynamic link domain and add it to authorised domains in Authentication settings
  3. Add below package
identity_firebase_link: ^0.1.0
  1. Add following code to initState of main page
import 'package:identity/identity.dart';
import 'package:identity_firebase/identity_firebase.dart';
import 'package:identity_firebase_link/identity_firebase_link.dart';

// ...

@override
  void initState() {
    super.initState();
    Identity.of(context).init(
        FirebaseProvider([
          FirebaseEmailLinkAuthenticator(
              url: 'https://yourapp.firebaseapp.com',
              iOSBundleID: "com.example.app",
              androidPackageName: "com.example.app")
        ]),
        (context) => HomePage());
  }
  1. Run the app

Screenshot_1578638981 Screenshot_1578639120

0.2.2 #

  • Upgrade identity: ^0.2.2

0.2.0 #

  • Upgrade identity_firebase

0.1.1 #

  • Add processing message
  • Update README.md

0.1.0 #

  • Implement Sign In With Link

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  identity_firebase_link: ^0.2.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:identity_firebase_link/identity_firebase_link.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Apr 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (firebase_dynamic_links).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and identity_firebase_link.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
crypto ^2.1.3 2.1.4
firebase_auth ^0.15.3 0.15.5+3
firebase_dynamic_links ^0.3.0 0.3.0 0.5.0+11
flutter 0.0.0
identity ^0.2.0 0.2.2
identity_firebase ^0.2.0 0.2.2
shared_preferences ^0.5.6 0.5.6+3
sso ^0.2.0 0.2.0
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.11 1.14.12
convert 2.1.1
firebase 7.3.0
firebase_auth_platform_interface 1.1.7
firebase_auth_web 0.1.2
firebase_core 0.4.4+3
firebase_core_platform_interface 1.0.4
firebase_core_web 0.1.1+2
flutter_web_plugins 0.0.0
http 0.12.0+4
http_parser 3.1.4
js 0.6.1+1
matcher 0.12.6
meta 1.1.8
path 1.6.4
pedantic 1.9.0
plugin_platform_interface 1.0.2
quiver 2.1.3
shared_preferences_macos 0.0.1+6
shared_preferences_platform_interface 1.0.3
shared_preferences_web 0.1.2+4
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test