identity_firebase_google 0.3.0
identity_firebase_google: ^0.3.0 copied to clipboard

Flutter Android iOS web

Google SSO by Firebase for Identity package

1
likes
80 / 110
pub points
31 %
popularity

We analyzed this package on Feb 27, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 6 API elements (33.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:identity_firebase_google/identity_firebase_google.dart that imports:
  • package:identity_firebase_google/src/firebase_google_authenticator.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_auth^0.15.30.15.5+31.0.0
flutterflutter0.0.00.0.0
google_sign_in^4.1.14.5.95.0.0
identity^0.3.00.3.60.3.6
identity_firebase^0.3.00.3.00.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
emitter-1.2.01.2.0
firebase-7.3.39.0.0
firebase_auth_platform_interface-1.1.84.0.0
firebase_auth_web-0.1.3+11.0.0
firebase_core-0.4.51.0.0
firebase_core_platform_interface-1.0.44.0.0
firebase_core_web-0.1.1+21.0.0
flutter_web_plugins-0.0.00.0.0
google_sign_in_platform_interface-1.1.22.0.0
google_sign_in_web-0.9.20.10.0
http-0.12.20.13.0
http_parser-3.1.44.0.0
js-0.6.20.6.3
matcher-0.12.90.12.10
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
pedantic-1.9.21.10.0
plugin_platform_interface-1.0.32.0.0
quiver-2.1.53.0.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.15.3` on firebase_auth does not support the latest published version `1.0.0`

pubspec.yaml:14:18

   ╷
14 │   firebase_auth: ^0.15.3
   │                  ^^^^^^^
   ╵
The constraint `^4.1.1` on google_sign_in does not support the latest published version `5.0.0`

pubspec.yaml:15:19

   ╷
15 │   google_sign_in: ^4.1.1
   │                   ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.