identity_firebase_google 0.3.0

  • Readme
  • Changelog
  • Installing
  • 73

dart-identity-firebase-google #

Google SSO by Firebase for Identity package

0.3.0 #

  • Upgrade identity

0.2.3+1 #

  • Update error's message

0.2.3 #

  • Improve error catching

0.2.2 #

  • Upgrade identity: ^0.2.2

0.2.0+1 #

  • Reduce size of icon image

[0.2.0] - v0.2.0 #

  • Upgrade identity_firebase

[0.1.1] - v0.1.1 #

  • Use google_sign_in: ^4.1.1
  • Add message when processing
  • Add scopes

[0.1.0] - v0.1.0 #

  • Upgrade identity_firebase

[0.0.2] - v0.0.2 #

  • Fix log in issue

[0.0.1] - v0.0.1 #

  • Implement Google authenticator

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  identity_firebase_google: ^0.3.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:identity_firebase_google/identity_firebase_google.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
61
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
63
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:identity_firebase_google/identity_firebase_google.dart that imports:
  • package:identity_firebase_google/src/firebase_google_authenticator.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: android, ios, web

Package does not support Flutter platform macos

Because:

  • package:identity_firebase_google/identity_firebase_google.dart that imports:
  • package:identity_firebase_google/src/firebase_google_authenticator.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: android, ios, web

Package does not support Flutter platform windows

Because:

  • package:identity_firebase_google/identity_firebase_google.dart that imports:
  • package:identity_firebase_google/src/firebase_google_authenticator.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: android, ios, web

Package not compatible with SDK dart

Because:

  • identity_firebase_google that is a package requiring null.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (firebase_auth).

The package description is too short. (-17 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and identity_firebase_google.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
firebase_auth ^0.15.3 0.15.5+3 0.16.1
flutter 0.0.0
google_sign_in ^4.1.1 4.5.1
identity ^0.3.0 0.3.6
identity_firebase ^0.3.0 0.3.0
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
emitter 1.2.0
firebase 7.3.0
firebase_auth_platform_interface 1.1.8
firebase_auth_web 0.1.3+1
firebase_core 0.4.5
firebase_core_platform_interface 1.0.4
firebase_core_web 0.1.1+2
flutter_web_plugins 0.0.0
google_sign_in_platform_interface 1.1.2
google_sign_in_web 0.9.1+1
http 0.12.1
http_parser 3.1.4
js 0.6.2
matcher 0.12.8
meta 1.1.8 1.2.2
path 1.7.0
pedantic 1.9.0 1.9.2
plugin_platform_interface 1.0.2
quiver 2.1.3
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test