hy_theme 0.0.1
hy_theme: ^0.0.1 copied to clipboard

Flutter Android iOS web

A new Flutter package.

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Jan 26, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis http://a.gitlab.local:10080/flutter/hy was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 19 API elements (47.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/hy_theme.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/custom_themes.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
list_ext^0.1.130.1.150.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
matcher-0.12.90.12.10-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
quiver-2.1.52.1.5
stack_trace-1.9.61.10.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.13` on list_ext does not support the latest published version `0.2.0`

pubspec.yaml:14:13

   ╷
14 │   list_ext: ^0.1.13
   │             ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

A new Flutter package.

Homepage

Documentation

API reference

Uploader

soccersports310@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, list_ext

More

Packages that depend on hy_theme