http_solver 0.1.2
http_solver: ^0.1.2 copied to clipboard

Flutter Android iOS macOS

A package help you to make api call and handle error faster, also you can check for internet before call api.

9
likes
70 / 110
pub points
42 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 17 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:http_solver/http_solver.dart that imports:
  • package:http_solver/src/httpsolver.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^0.4.6+20.4.9+53.0.0
dartz^0.9.0-dev.50.9.20.9.2
flutterflutter0.0.00.0.0
http^0.12.0+40.12.20.13.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
connectivity_for_web-0.3.1+40.3.1+4
connectivity_macos-0.1.0+70.2.0
connectivity_platform_interface-1.0.62.0.0
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
pedantic-1.9.21.10.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.6+2` on connectivity does not support the latest published version `3.0.0`

pubspec.yaml:18:17

   ╷
18 │   connectivity: ^0.4.6+2
   │                 ^^^^^^^^
   ╵
The constraint `^0.12.0+4` on http does not support the latest published version `0.13.0`

pubspec.yaml:17:9

   ╷
17 │   http: ^0.12.0+4
   │         ^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

9
likes
70
pub points
42%
popularity

A package help you to make api call and handle error faster, also you can check for internet before call api.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

abdoo.dev@gmail.com

License

MIT (LICENSE)

Dependencies

connectivity, dartz, flutter, http

More

Packages that depend on http_solver