http_server 1.0.0 copy "http_server: ^1.0.0" to clipboard
http_server: ^1.0.0 copied to clipboard

discontinuedreplaced by: shelf

Library of HTTP server classes.

32
likes
100/ 140
pub points
88%
popularity

We analyzed this package 4 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

41 out of 42 API elements (97.6 %) have documentation comments.

Some symbols that are missing documentation: http_server.VirtualDirectory.root.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:http_server/http_server.dart that imports:
  • package:http_server/src/http_multipart_form_data.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

WARNING: The ability to import 'BytesBuilder' indirectly is deprecated.

lib/src/http_body.dart:222:37

    ╷
222 │     var builder = await stream.fold<BytesBuilder>(
    │                                     ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/http_body.dart

WARNING: The ability to import 'BytesBuilder' indirectly is deprecated.

lib/src/http_body.dart:223:9

    ╷
223 │         BytesBuilder(), (builder, data) => builder..add(data));
    │         ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/http_body.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
mime ^1.0.0 1.0.5 1.0.5
path ^1.8.0 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

32
likes
100
pub points
88%
popularity

Publisher

verified publisherlabs.dart.dev

Library of HTTP server classes.

Repository
View/report issues
Contributing

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

mime, path

More

Packages that depend on http_server