http 0.12.2

Dart native js
Flutter Android iOS web

A composable, multi-platform, Future-based API for HTTP requests.

1007
likes
110 / 110
pub points
100 %
popularity

We analyzed this package on Aug 11, 2020, and awarded it 110 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 105 out of 134 API elements (78.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http_parser>=0.0.1 <4.0.03.1.43.1.4
path>=0.9.0 <2.0.01.7.01.7.0
pedantic^1.0.01.9.21.9.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
meta-1.2.21.2.2
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1007
likes
110
pub points
100%
popularity

Publisher

dart.dev

A composable, multi-platform, Future-based API for HTTP requests.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

http_parser, path, pedantic

More

Packages that depend on http