hive_repository 1.0.4 copy "hive_repository: ^1.0.4" to clipboard
hive_repository: ^1.0.4 copied to clipboard

A DatabaseAdapter for the hive database as used by the database_repository package

1
likes
110/ 140
pub points
53%
popularity

We analyzed this package 6 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

19 out of 20 API elements (95.0 %) have documentation comments.

Some symbols that are missing documentation: hive_repository.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: Unused import: '../deps.dart'.

lib/src/database/query_executor.dart:4:8

  ╷
4 │ import '../deps.dart';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/database/query_executor.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
database_repository ^2.0.0 2.0.1 2.0.1
hive ^2.0.5 2.2.3 2.2.3
meta ^1.7.0 1.15.0 1.15.0
uuid ^3.0.5 3.0.7 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.5` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

1
likes
110
pub points
53%
popularity

Publisher

verified publisherglassp.dev

A DatabaseAdapter for the hive database as used by the database_repository package

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

database_repository, hive, meta, uuid

More

Packages that depend on hive_repository