hive_repository 1.0.4 copy "hive_repository: ^1.0.4" to clipboard
hive_repository: ^1.0.4 copied to clipboard

A DatabaseAdapter for the hive database as used by the database_repository package

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add hive_repository

With Flutter:

 $ flutter pub add hive_repository

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  hive_repository: ^1.0.4

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:hive_repository/hive_repository.dart';
1
likes
110
pub points
53%
popularity

Publisher

verified publisherglassp.dev

A DatabaseAdapter for the hive database as used by the database_repository package

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

database_repository, hive, meta, uuid

More

Packages that depend on hive_repository