hive_cache_interceptor 1.0.0-dev.3
hive_cache_interceptor: ^1.0.0-dev.3 copied to clipboard

Package to implements cache using hive in hasura_connect package

7
likes
60 / 130
pub points
69 %
popularity

We analyzed this package on Apr 20, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 3 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:hive_cache_interceptor/hive_cache_interceptor.dart that imports:
  • package:hive_cache_interceptor/src/hive_storage_service.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/hive_cache_interceptor.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/hive_storage_service.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
hasura_cache_interceptor>=1.0.0-dev.5 <2.0.01.0.0-dev.51.0.0-dev.5
hive^1.6.0-nullsafety.21.6.0-nullsafety.22.0.4
path_provider^2.0.12.0.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
dart_websocket-1.0.01.0.0
either_dart-0.1.10.1.1
ffi-1.0.01.0.0
file-6.1.06.1.0
hasura_connect-3.0.0+13.0.0+1
http-0.13.10.13.1
http_parser-4.0.04.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider_linux-2.0.02.0.0
path_provider_macos-2.0.02.0.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.02.0.0
pedantic-1.11.01.11.0
platform-3.0.03.0.0
plugin_platform_interface-2.0.02.0.0
process-4.2.14.2.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
string_validator-0.2.0-nullsafety.00.3.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.43.0.4
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.2.00.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.6.0-nullsafety.2` on hive does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions hive to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Tag detection failed.

Broken import dart:indexed_db

For more information

Try running pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.