high_chart 2.0.3 icon indicating copy to clipboard operation
high_chart: ^2.0.3 copied to clipboard

A chart library based on High Charts (.JS), able to build advanced charts like Pie chart, linear chart, etc.

52
likes
130/ 130
pub points
83%
popularity

We analyzed this package 43 hours ago, and awarded it 130 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 13 API elements (61.5 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:high_chart/high_chart.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:high_chart/high_chart.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:high_chart/high_chart.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:high_chart/high_chart.dart that imports:
  • package:high_chart/src/mobile/high_chart.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:high_chart/high_chart.dart that imports:
  • package:high_chart/src/mobile/high_chart.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_surface_android.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_web_pluginsflutter0.0.00.0.0
js^0.6.30.6.40.6.4
url_launcher^6.1.06.1.56.1.5
webview_flutter^3.0.23.0.43.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
collection-1.16.01.16.0
material_color_utilities-0.1.40.2.0
meta-1.7.01.8.0
path-1.8.21.8.2
plugin_platform_interface-2.1.22.1.2
sky_engine-0.0.990.0.99
url_launcher_android-6.0.176.0.17
url_launcher_ios-6.0.176.0.17
url_launcher_linux-3.0.13.0.1
url_launcher_macos-3.0.13.0.1
url_launcher_platform_interface-2.1.02.1.0
url_launcher_web-2.0.132.0.13
url_launcher_windows-3.0.13.0.1
vector_math-2.1.22.1.2
webview_flutter_android-2.9.32.9.3
webview_flutter_platform_interface-1.9.11.9.1
webview_flutter_wkwebview-2.9.32.9.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.15, Flutter 3.0.5, Dart 2.17.6.

52
likes
130
pub points
83%
popularity

Publisher

verified publisher iconsenthilnasa.me

A chart library based on High Charts (.JS), able to build advanced charts like Pie chart, linear chart, etc.

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, flutter_web_plugins, js, url_launcher, webview_flutter

More

Packages that depend on high_chart