graphql_server 2.0.0-beta
graphql_server: ^2.0.0-beta copied to clipboard

Base package for implementing GraphQL servers. You might prefer `package:angel_graphql`, the fastest way to implement GraphQL backends in Dart.

7
likes
70 / 110
pub points
69 %
popularity

We analyzed this package on Apr 7, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 104 API elements (20.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: The getter 'message' isn't defined for the type 'TypeError'.

lib/graphql_server.dart:465:17

    ╷
465 │               e.message.toString(),
    │                 ^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/graphql_server.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_serialize^2.0.02.2.3+32.2.3+3
collection^1.0.01.15.01.15.0
gql^0.12.00.12.40.12.4
graphql_schema^1.0.01.0.41.0.4
meta^1.0.01.3.01.3.0
recase^2.0.02.0.13.0.1
stream_channel^2.0.02.1.02.1.0
tuple^1.0.01.0.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_model-1.0.31.0.3
async-2.5.02.5.0
matcher-0.12.100.12.10
path-1.8.01.8.0
quiver-2.1.53.0.1
quiver_hashcode-2.0.03.0.0+1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
term_glyph-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on recase does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions recase to update the constraint.

The constraint `^1.0.0` on tuple does not support the stable version `2.0.0`, that was published 26 days ago.

When tuple is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions tuple to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

7
likes
70
pub points
69%
popularity

Base package for implementing GraphQL servers. You might prefer `package:angel_graphql`, the fastest way to implement GraphQL backends in Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

thosakwe@gmail.com

License

MIT (LICENSE)

Dependencies

angel_serialize, collection, gql, graphql_schema, meta, recase, stream_channel, tuple

More

Packages that depend on graphql_server