graphql_server 1.0.3
graphql_server: ^1.0.3 copied to clipboard

Base package for implementing GraphQL servers. You might prefer `package:angel_graphql`, the fastest way to implement GraphQL backends in Dart.

7
likes
60 / 130
pub points
67 %
popularity

We analyzed this package on May 13, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 90 API elements (13.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

ERROR: The getter 'message' isn't defined for the type 'TypeError'.

lib/graphql_server.dart:475:17

    ╷
475 │               e.message.toString(),
    │                 ^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/graphql_server.dart

INFO: The for, if, and spread elements weren't supported until version 2.3.0, but this code is required to be able to run on earlier versions.

lib/graphql_server.dart:36:45

   ╷
36 │       var allTypes = fetchAllTypes(schema, [...this.customTypes]);
   │                                             ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/graphql_server.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_serialize^2.0.02.2.3+32.2.3+3
collection^1.0.01.15.01.15.0
graphql_parser^1.0.01.1.41.1.4
graphql_schema^1.0.01.0.41.0.4
meta^1.0.01.3.01.3.0
recase^2.0.02.0.14.0.0
stream_channel^2.0.02.1.02.1.0
tuple^1.0.01.0.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_model-1.0.31.0.3
async-2.6.12.6.1
charcode-1.2.01.2.0
matcher-0.12.100.12.10
path-1.8.01.8.0
quiver-2.1.53.0.1
quiver_hashcode-2.0.03.0.0+1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on recase does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions recase to update the constraint.

The constraint `^1.0.0` on tuple does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions tuple to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

7
likes
60
pub points
67%
popularity

Base package for implementing GraphQL servers. You might prefer `package:angel_graphql`, the fastest way to implement GraphQL backends in Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

thosakwe@gmail.com

License

MIT (LICENSE)

Dependencies

angel_serialize, collection, graphql_parser, graphql_schema, meta, recase, stream_channel, tuple

More

Packages that depend on graphql_server