gql_exec 1.0.0+1 copy "gql_exec: ^1.0.0+1" to clipboard
gql_exec: ^1.0.0+1 copied to clipboard

Basis for GraphQL execution layer to support Link and Client.

1
likes
140/ 160
pub points
91%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

53 out of 59 API elements (89.8 %) have documentation comments.

Some symbols that are missing documentation: execution.ContextUpdater, execution.ErrorLocation.column, execution.ErrorLocation.line, execution.GetRequestExtensions, execution.OperationTypeExtension.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'whereNotNull' is deprecated and shouldn't be used. Use .nonNulls instead.

lib/src/operation_operationtype_extension.dart:12:10

   ╷
12 │         .whereNotNull()
   │          ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/operation_operationtype_extension.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.19.0 1.19.0
gql ^1.0.0+1 1.0.0+1 1.0.0+1
meta ^1.3.0 1.15.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

1
likes
140
pub points
91%
popularity

Publisher

verified publishergql-dart.dev

Basis for GraphQL execution layer to support Link and Client.

Repository (GitHub)
View/report issues

Topics

#graphql #gql

Documentation

API reference

License

MIT (license)

Dependencies

collection, gql, meta

More

Packages that depend on gql_exec