gql_build 0.1.4+2
gql_build: ^0.1.4+2 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

Useful builders for your GraphQL SDL and documents. Based on package:gql_code_builder and package:build

5
likes
90 / 110
pub points
73 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 7 API elements (85.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:gql_build/gql_build.dart that imports:
  • package:gql_build/src/serializer_builder.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/task/api/model.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.140.39.171.1.0
build^1.0.01.6.21.6.3
built_collection^4.3.24.3.25.0.0
built_value^7.1.07.1.08.0.0
built_value_generator^7.1.07.1.08.0.0
code_builder^3.3.03.6.03.6.0
dart_style^1.2.91.3.61.3.14
glob^1.2.01.2.02.0.0
gql^0.12.40.12.40.12.4
gql_code_builder^0.1.40.1.4+10.1.4+1
path^1.6.41.7.01.8.0
yaml^2.2.12.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.017.0.0
args-1.6.02.0.0
async-2.4.22.5.0
build_config-0.4.60.4.6
charcode-1.1.31.2.0
checked_yaml-1.0.42.0.0
cli_util-0.2.00.3.0
collection-1.14.131.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
csslib-0.16.20.17.0
file-5.2.16.1.0
fixnum-0.10.111.0.0
gql_exec-0.2.50.2.5
html-0.14.0+40.15.0
intl-0.16.10.17.0
js-0.6.20.6.3
json_annotation-3.1.14.0.0
logging-0.11.41.0.0
matcher-0.12.90.12.10
meta-1.2.41.3.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
pedantic-1.9.21.10.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.80.1.8
quiver-2.1.53.0.0
recase-3.0.13.0.1
source_gen-0.9.10+20.9.10+3
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0
watcher-0.9.7+151.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^0.39.14` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^4.3.2` on built_collection does not support the stable version `5.0.0`, that was published 20 days ago.

When built_collection is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions built_collection to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

5
likes
90
pub points
73%
popularity

Publisher

gql-dart.dev

Useful builders for your GraphQL SDL and documents. Based on package:gql_code_builder and package:build

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, built_collection, built_value, built_value_generator, code_builder, dart_style, glob, gql, gql_code_builder, path, yaml

More

Packages that depend on gql_build