gooyaan 0.0.13
gooyaan: ^0.0.13 copied to clipboard

Gooyaan flutter plugin for show the posts on your own application.

2
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 30 out of 108 API elements (27.8 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Android`.

Because:

  • package:gooyaan/gooyaan.dart that declares support for platforms: Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
apex_flutter_plugin^1.0.341.1.1+12.0.4
cached_network_image^2.1.0+12.5.13.1.0
carousel_slider^2.1.02.3.44.0.0
chewie^0.9.100.9.101.2.2
flare_flutter^2.0.32.0.63.0.2
flutterflutter0.0.00.0.0
image_picker^0.6.40.6.6+50.8.4+3
quill_delta_plus^0.0.10.0.10.0.1
share^0.6.3+60.6.5+42.0.4
shared_preferences^0.5.6+30.5.12+42.0.8
url_launcher^5.4.25.7.106.0.12
video_player^0.10.110.10.12+52.2.5
zefyr_plus^0.10.80.10.80.10.8
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.63.1.6
args-2.3.02.3.0
asn1lib-1.0.21.0.2
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clipboard_manager-0.0.40.0.4
clock-1.1.01.1.0
collection-1.15.01.15.0
connectivity-3.0.63.0.6
connectivity_for_web-0.4.0+10.4.0+1
connectivity_macos-0.2.1+20.2.1+2
connectivity_platform_interface-2.0.02.0.1
convert-3.0.13.0.1
crypto-3.0.13.0.1
csslib-0.17.10.17.1
encrypt-5.0.15.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flare_dart-2.3.42.3.4
flutter_blurhash-0.5.00.6.0
flutter_cache_manager-2.1.23.1.2
flutter_plugin_android_lifecycle-1.0.112.0.4
flutter_web_plugins-0.0.00.0.0
html-0.15.00.15.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
image-3.0.83.0.8
image_picker_platform_interface-1.0.02.4.1
js-0.6.30.6.3
meta-1.7.01.7.0
mime-0.9.71.0.1
notus_plus-0.1.60.1.6
octo_image-0.3.01.0.0+1
open_iconic_flutter-0.3.00.3.0
path-1.8.01.8.0
path_provider-1.6.282.0.5
path_provider_linux-0.0.1+22.1.0
path_provider_macos-0.0.4+82.0.2
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.3
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
pointycastle-3.3.43.3.4
process-4.2.44.2.4
quiver_hashcode-2.0.03.0.0+1
rxdart-0.25.00.27.2
shared_preferences_linux-0.0.2+42.0.2
shared_preferences_macos-0.0.1+112.0.2
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.2
shared_preferences_windows-0.0.2+32.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
universal_html-2.0.82.0.8
universal_io-2.0.42.0.4
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.4
url_launcher_windows-0.0.1+32.0.2
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
video_player_platform_interface-2.2.04.2.0
video_player_web-0.1.4+12.0.4
wakelock-0.1.4+20.5.6
win32-2.2.102.2.10
xdg_directories-0.1.20.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 10 issues. Showing the first 2:

The constraint `^1.0.34` on apex_flutter_plugin does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions apex_flutter_plugin to update the constraint.

The constraint `^2.1.0+1` on cached_network_image does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.