zefyr_plus 0.10.5

  • Readme
  • Changelog
  • Installing
  • 64

Zefyr Build Status codecov #

Soft and gentle rich text editing for Flutter applications.

Zefyr is currently in early preview. If you have a feature request or found a bug, please file it at the issue tracker.

For documentation see https://github.com/memspace/zefyr.

zefyr screenshot

Installation #

Official releases of Zefyr can be installed from Dart's Pub package repository.

Note that versions from Pub track stable channel of Flutter.

To install Zefyr from Pub add zefyr package as a dependency to your pubspec.yaml:

dependencies:
  zefyr: [latest_version]

And run flutter packages get.

Continue to https://github.com/memspace/zefyr/blob/master/doc/concepts/quick_start.md to learn more about Zefyr and how to use it in your projects.

0.10.5 #

Add video into your zefyr view and editor

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  zefyr_plus: ^0.10.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:zefyr_plus/util.dart';
import 'package:zefyr_plus/zefyr.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
52
Health:
Code health derived from static analysis. [more]
72
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform windows

Because:

  • package:zefyr_plus/zefyr.dart that imports:
  • package:zefyr_plus/src/widgets/view.dart that imports:
  • package:zefyr_plus/src/widgets/scope.dart that imports:
  • package:zefyr_plus/src/widgets/editor.dart that imports:
  • package:zefyr_plus/src/widgets/toolbar.dart that imports:
  • package:zefyr_plus/src/widgets/buttons.dart that imports:
  • package:url_launcher/url_launcher.dart that declares support for platforms: android, ios, linux, macos, web

Package not compatible with SDK dart

Because:

  • zefyr_plus that is a package requiring null.

Health issues and suggestions

Fix lib/src/widgets/__theme.dart. (-14.26 points)

Analysis of lib/src/widgets/__theme.dart reported 3 warnings:

line 231 col 5: Missing case clause for 'linux'.

line 231 col 5: Missing case clause for 'macOS'.

line 231 col 5: Missing case clause for 'windows'.

Fix lib/src/widgets/common.dart. (-14.26 points)

Analysis of lib/src/widgets/common.dart reported 3 warnings:

line 63 col 7: Missing case clause for 'linux'.

line 63 col 7: Missing case clause for 'macOS'.

line 63 col 7: Missing case clause for 'windows'.

Fix lib/src/widgets/buttons.dart. (-1 points)

Analysis of lib/src/widgets/buttons.dart reported 2 hints:

line 612 col 35: 'subhead' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is subtitle1. This feature was deprecated after v1.13.8..

line 652 col 38: 'subhead' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is subtitle1. This feature was deprecated after v1.13.8..

Fix additional 6 files with analysis or formatting issues. (-0.50 points)

Additional issues in the following files:

  • lib/src/widgets/video.dart (1 hint)
  • lib/src/widgets/code.dart (Run flutter format to format lib/src/widgets/code.dart.)
  • lib/src/widgets/editable_text.dart (Run flutter format to format lib/src/widgets/editable_text.dart.)
  • lib/src/widgets/editor.dart (Run flutter format to format lib/src/widgets/editor.dart.)
  • lib/src/widgets/field.dart (Run flutter format to format lib/src/widgets/field.dart.)
  • lib/src/widgets/view.dart (Run flutter format to format lib/src/widgets/view.dart.)

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and zefyr_plus.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-10 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.2 <3.0.0
clipboard_manager ^0.0.4 0.0.4
collection ^1.14.6 1.14.12 1.14.13
flutter 0.0.0
meta ^1.1.0 1.1.8 1.2.2
notus_plus ^0.1.2 0.1.3
quill_delta ^1.0.0 1.0.2
quiver_hashcode ^2.0.0 2.0.0
url_launcher ^5.0.0 5.5.0
Transitive dependencies
flutter_web_plugins 0.0.0
platform_detect 1.4.0
plugin_platform_interface 1.0.2
pub_semver 1.4.4
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
url_launcher_linux 0.0.1+1
url_launcher_macos 0.0.1+7
url_launcher_platform_interface 1.0.7
url_launcher_web 0.1.2
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test
pedantic ^1.0.0