google_speech 5.2.0+1 copy "google_speech: ^5.2.0+1" to clipboard
google_speech: ^5.2.0+1 copied to clipboard

Flutter Plugin for the Google Cloud GRPC Speech-to-Text Api.

120
likes
130/ 160
pub points
93%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting google_speech... Discovering libraries... Linking elements... Precaching local docs for 667067 elements... Initialized dartdoc with 684 libraries Generating docs for library generated/google/protobuf/timestamp.pbjson.dart from package:google_speech/generated/google/protobuf/timestamp.pbjson.dart... Generating docs for library generated/google/protobuf/empty.pbjson.dart from package:google_speech/generated/google/protobuf/empty.pbjson.dart... Generating docs for library generated/google/protobuf/wrappers.pbjson.dart from package:google_speech/generated/google/protobuf/wrappers.pbjson.dart... Generating docs for library generated/google/protobuf/empty.pbenum.dart from package:google_speech/generated/google/protobuf/empty.pbenum.dart... Generating docs for library generated/google/protobuf/duration.pbenum.dart from package:google_speech/generated/google/protobuf/duration.pbenum.dart... [67 more lines] ERR: warning: private API of package:googleapis_auth is reexported by libraries in other packages: from google_speech.AccessCredentials.AccessCredentials: (file:///tmp/analyzerJPKGMR/pub-cache/hosted/20240606t114600-dot-dartlang-pub.appspot.com/googleapis_auth-1.6.0/lib/src/access_credenti[...] referred to by google_speech: (file:///tmp/pana_SZRACG/lib/google_speech.dart:1:1) warning: private API of package:googleapis_auth is reexported by libraries in other packages: from google_speech.AccessCredentials.fromJson: (file:///tmp/analyzerJPKGMR/pub-cache/hosted/20240606t114600-dot-dartlang-pub.appspot.com/googleapis_auth-1.6.0/lib/src/access_credentials.dart:[...] referred to by google_speech: (file:///tmp/pana_SZRACG/lib/google_speech.dart:1:1) The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. [1734 more lines]

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:google_speech/google_speech.dart that imports:
  • package:google_speech/auth/third_party_authenticator.dart that imports:
  • package:grpc/grpc.dart that imports:
  • package:grpc/src/shared/streams.dart that imports:
  • package:http2/transport.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'false'.

lib/speech_client_authenticator.dart:49:14

   ╷
49 │     if (file == null || !file.existsSync()) throw FileNotFoundException(file);
   │              ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/speech_client_authenticator.dart

WARNING: Unused import: 'dart:collection'.

lib/speech_to_text.dart:4:8

  ╷
4 │ import 'dart:collection';
  │        ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/speech_to_text.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
fixnum ^1.1.0 1.1.0 1.1.0
flutter flutter 0.0.0 0.0.0
googleapis_auth ^1.4.1 1.6.0 1.6.0
grpc ^3.2.4 3.2.4 3.2.4
http ^1.2.0 1.2.1 1.2.1
meta ^1.9.1 1.12.0 1.15.0
path_provider ^2.1.2 2.1.3 2.1.3
protobuf ^3.1.0 3.1.0 3.1.0
rxdart ^0.27.7 0.27.7 0.27.7
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.1 3.6.1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
google_identity_services_web - 0.3.1+1 0.3.1+1
http2 - 2.3.0 2.3.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.12.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.5 2.2.5
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.5, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.