google_maps_place_picker 1.0.1
google_maps_place_picker: ^1.0.1 copied to clipboard

A Flutter plugin which provides 'Picking Place' using Google Maps widget.

192
likes
65/ 130
pub points
97%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:144:70

    ╷
144 │ adrAddress | String | A representation of the place's address in the <a href="http://microformats.org/wiki/adr">adr microformat</a>
    │                                                                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 16 out of 149 API elements (10.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:google_maps_place_picker/google_maps_place_picker.dart that imports:
  • package:google_maps_place_picker/src/place_picker.dart that imports:
  • package:google_maps_place_picker/src/google_map_place_picker.dart that imports:
  • package:google_maps_place_picker/providers/place_provider.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/google_map_place_picker.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/place_picker.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
geolocator^6.0.0+46.2.17.7.0
google_maps_flutter^1.0.61.2.02.0.11
google_maps_webservice^0.0.160.0.190.0.19
http^0.12.0+40.12.20.13.4
permission_handler^5.0.1+15.1.0+28.2.5
provider^4.0.14.3.36.0.1
tuple^1.0.31.0.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
flutter_plugin_android_lifecycle-1.0.112.0.4
flutter_web_plugins-0.0.00.0.0
geolocator_platform_interface-1.0.92.3.6
geolocator_web-1.0.12.0.6
google_maps_flutter_platform_interface-1.2.02.1.3
http_parser-3.1.44.0.0
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
nested-1.0.01.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
permission_handler_platform_interface-2.0.23.7.0
plugin_platform_interface-1.0.32.0.2
quiver-2.1.53.0.1+1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_transform-1.2.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^6.0.0+4` on geolocator does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions geolocator to update the constraint.

The constraint `^1.0.6` on google_maps_flutter does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions google_maps_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.