google_maps_directions 0.0.4 copy "google_maps_directions: ^0.0.4" to clipboard
google_maps_directions: ^0.0.4 copied to clipboard

Calculate distances, durations & Get shortest route/leg between two points.

19
likes
140/ 160
pub points
88%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

42 out of 151 API elements (27.8 %) have documentation comments.

Some symbols that are missing documentation: google_maps_directions, google_maps_directions.AddressPoint, google_maps_directions.AddressPoint.AddressPoint, google_maps_directions.AddressPoint.copyWith, google_maps_directions.AddressPoint.AddressPoint.fromJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

WARNING: Doc directive is missing an opening tag.

lib/src/functions/computation/distance.dart:18:5

   ╷
18 │ /// {@end-tool}
   │     ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/functions/computation/distance.dart

WARNING: Doc directive is missing an opening tag.

lib/src/functions/computation/distance.dart:48:5

   ╷
48 │ /// {@end-tool}
   │     ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/functions/computation/distance.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.5 2.0.5 2.0.5
http ^1.1.0 1.2.1 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
http_parser - 4.1.0 4.1.0
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

19
likes
140
pub points
88%
popularity

Publisher

verified publishertheresilient.dev

Calculate distances, durations & Get shortest route/leg between two points.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

BSD-3-Clause (LICENSE)

Dependencies

equatable, http

More

Packages that depend on google_maps_directions