google_map_location_picker 4.0.0

Flutter Android

🌍 Map location picker for flutter Based on google_maps_flutter

112
likes
65 / 110
pub points
97 %
popularity

We analyzed this package on Oct 29, 2020, and awarded it 65 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:53:61

   ╷
53 │ <li>Prepare for 1.0.0 version of sensors and package_info. (<a href="http://github.com/amirh/dart_lsc">dart_lsc</a>)</li>
   │                                                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 57 out of 148 API elements (38.5 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform iOS

Because:

  • package:google_map_location_picker/google_map_location_picker.dart that declares support for platforms: Android
Package does not support Flutter platform Web

Because:

  • package:google_map_location_picker/google_map_location_picker.dart that declares support for platforms: Android

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:google_map_location_picker/google_map_location_picker.dart that declares support for platforms: Android
Package does not support Flutter platform Linux

Because:

  • package:google_map_location_picker/google_map_location_picker.dart that declares support for platforms: Android
Package does not support Flutter platform macOS

Because:

  • package:google_map_location_picker/google_map_location_picker.dart that declares support for platforms: Android
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

INFO: 'getCurrentPosition' is deprecated and shouldn't be used. Call Geolocator.getCurrentPosition() instead.This feature was deprecated after 6.0.0+4..

lib/src/map.dart:98:17

   ╷
98 │           await getCurrentPosition(desiredAccuracy: widget.desiredAccuracy);
   │                 ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/map.dart

INFO: 'checkPermission' is deprecated and shouldn't be used. Call Geolocator.checkPermission() instead.This feature was deprecated after 6.0.0+4..

lib/src/map.dart:327:37

    ╷
327 │     final geolocationStatus = await checkPermission();
    │                                     ^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/map.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
android_intent^0.3.7+40.3.7+60.3.7+6
flutterflutter0.0.00.0.0
flutter_localizationsflutter0.0.00.0.0
geolocator^6.0.0+46.1.16.1.1
google_maps_flutter^1.0.21.0.51.0.5
http^0.12.20.12.20.12.2
intl>=0.16.0 <=0.16.10.16.10.16.1
intl_translation>=0.17.9 <=0.17.100.17.100.17.10+1
package_info>=0.4.0+14 <2.0.00.4.30.4.3
provider^4.3.2+24.3.2+24.3.2+2
stack_trace^1.9.51.9.51.10.0-nullsafety.5
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.012.0.0
analyzer-0.39.170.40.5
args-1.6.01.6.0
async-2.4.22.5.0-nullsafety.2
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
charcode-1.1.31.2.0-nullsafety.2
cli_util-0.2.00.2.0
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.61.3.8
flutter_plugin_android_lifecycle-1.0.111.0.11
geolocator_platform_interface-1.0.51.0.5
glob-1.2.01.2.0
google_maps_flutter_platform_interface-1.0.41.0.4
html-0.14.0+40.14.0+4
http_parser-3.1.43.1.4
js-0.6.20.6.2
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
nested-0.0.40.0.4
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.8.0-nullsafety.11.8.0-nullsafety.2
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
pub_semver-1.4.41.4.4
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.3
stream_transform-1.2.01.2.0
string_scanner-1.0.51.1.0-nullsafety.2
term_glyph-1.1.01.2.0-nullsafety.2
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.17.9 <=0.17.10` on intl_translation does not support the latest published version `0.17.10+1`

pubspec.yaml:18:21

   ╷
18 │   intl_translation: '>=0.17.9 <=0.17.10'
   │                     ^^^^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs