glob 1.2.0

Dart native
Flutter Android iOS

Bash-style filename globbing.

9
likes
80 / 110
pub points
99 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 11 API elements (90.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async>=1.2.0 <3.0.02.4.22.4.2
collection^1.1.01.14.131.14.13
node_io^1.0.01.1.11.1.1
path^1.3.01.7.01.7.0
pedantic^1.2.01.9.21.9.2
string_scanner>=0.1.0 <2.0.01.0.51.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
js-0.6.20.6.2
meta-1.2.31.2.3
node_interop-1.1.11.1.1
source_span-1.7.01.7.0
term_glyph-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs