git2dart 0.1.0 copy "git2dart: ^0.1.0" to clipboard
git2dart: ^0.1.0 copied to clipboard

Dart bindings to libgit2, provides ability to use libgit2 library in Dart and Flutter.

3
likes
130/ 140
pub points
35%
popularity

We analyzed this package 8 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

783 out of 885 API elements (88.5 %) have documentation comments.

Some symbols that are missing documentation: git2dart.AnnotatedCommit, git2dart.Blame, git2dart.BlameHunk, git2dart.Blob, git2dart.Branch.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:git2dart/git2dart.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:git2dart/git2dart.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:git2dart/git2dart.dart that declares support for platforms: Windows, Linux, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/bindings/reference.dart:143:36

    ╷
143 │       result.add(array.ref.strings.elementAt(i).value.toDartString());
    │                                    ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bindings/reference.dart

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/libgit2.dart:486:27

    ╷
486 │         array.ref.strings.elementAt(i).value.toDartString()
    │                           ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/libgit2.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.5 2.0.5 2.0.5
ffi ^2.0.1 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
git2dart_binaries ^0.3.0 0.3.0 0.3.0
meta ^1.8.0 1.12.0 1.15.0
path ^1.8.1 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
plugin_platform_interface - 2.1.8 2.1.8
pub_semver - 2.1.4 2.1.4
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

3
likes
130
pub points
35%
popularity

Publisher

verified publisherdartgit.dev

Dart bindings to libgit2, provides ability to use libgit2 library in Dart and Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable, ffi, flutter, git2dart_binaries, meta, path

More

Packages that depend on git2dart