get_version 0.2.2
get_version: ^0.2.2 copied to clipboard

Flutter Android iOS

Get the Version Name, Version Code, Platform and OS Version, and App ID on iOS and Android.

54
likes
85 / 110
pub points
96 %
popularity

We analyzed this package on Mar 3, 2021, and awarded it 85 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:3:61

  ╷
3 │ <li>Prepare for 1.0.0 version of sensors and package_info. (<a href="http://github.com/amirh/dart_lsc">dart_lsc</a>)</li>
  │                                                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 8 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:get_version/get_version.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
package_info>=0.4.0+13 <2.0.00.4.3+42.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.4.0+13 <2.0.0` on package_info does not support the stable version `2.0.0`, that was published 11 days ago.

When package_info is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions package_info to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

54
likes
85
pub points
96%
popularity

Publisher

fluttercommunity.dev

Get the Version Name, Version Code, Platform and OS Version, and App ID on iOS and Android.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, package_info

More

Packages that depend on get_version