geoimage 0.1.2+2
geoimage: ^0.1.2+2 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

A geo-wrapper around the image project (https://pub.dev/packages/image)

0
likes
80 / 110
pub points
55 %
popularity

We analyzed this package on Feb 25, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 57 out of 127 API elements (44.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:geoimage/geoimage.dart that imports:
  • package:geoimage/src/com/hydrologis/geoimage/core/utils.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Unused import: 'dart:convert'.

lib/src/com/hydrologis/geoimage/core/geoinfo.dart:1:8

  ╷
1 │ import 'dart:convert';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/com/hydrologis/geoimage/core/geoinfo.dart

INFO: Prefer using /// for doc comments.

lib/src/com/hydrologis/geoimage/core/utils.dart:329:3

    ╷
329 │ ┌   /**
330 │ │      * Normalizes a value for a given normalization max (assuming the lower is 0).
331 │ │      * 
332 │ │      * @param max the max of the sampling values.
333 │ │      * @param min the min of the sampling values.
334 │ │      * @param value the current value from the sampling values to be normalized.
335 │ │      * @param normMax the normalization maximum to use.
336 │ │      * @return the normalized value.
337 │ └      */
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/com/hydrologis/geoimage/core/utils.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dart_jts^0.0.70.0.7+20.0.7+2
image>=2.1.19 <=3.0.0-nullsafety.02.1.192.1.19
path^1.7.01.7.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.0.0
args-1.6.02.0.0
charcode-1.1.31.2.0
collection-1.14.131.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
intl-0.16.10.17.0
meta-1.2.41.3.0
petitparser-3.1.04.0.2
typed_data-1.2.01.3.0
xml-4.5.15.0.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

0
likes
80
pub points
55%
popularity

A geo-wrapper around the image project (https://pub.dev/packages/image)

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

andrea.antonello@hydrologis.com

License

Apache 2.0 (LICENSE)

Dependencies

dart_jts, image, path

More

Packages that depend on geoimage