geofence_flutter 1.1.0
geofence_flutter: ^1.1.0 copied to clipboard

Flutter geofencing plugin for flutter application (android and ios).

13
likes
100/ 130
pub points
56%
popularity

We analyzed this package on Sep 20, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 11 API elements (54.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:geofence_flutter/geofence_flutter.dart that imports:
  • package:geolocator/geolocator.dart that declares support for platforms: Android, iOS, Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
geolocator^6.1.136.2.17.6.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
flutter_web_plugins-0.0.00.0.0
geolocator_platform_interface-1.0.92.3.5
geolocator_web-1.0.12.0.6
js-0.6.30.6.3
meta-1.7.01.7.0
plugin_platform_interface-1.0.32.0.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^6.1.13` on geolocator does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions geolocator to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

13
likes
100
pub points
56%
popularity

Publisher

sarfaraz.me

Flutter geofencing plugin for flutter application (android and ios).

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, geolocator

More

Packages that depend on geofence_flutter