geodata 0.4.0-nullsafety.0 icon indicating copy to clipboard operation
geodata: ^0.4.0-nullsafety.0 copied to clipboard

A geospatial client reading OGC API and other geospatial data sources.

2
likes
80/ 120
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 80 pub points (of a possible 120):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 10icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/geodata_example.dart
icon indicating section status
Support multiple platforms
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 2 possible platforms (native, js)

icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/source/oapi/features/feature_provider_oapif.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
attributes^0.4.0-nullsafety.00.4.0-nullsafety.00.8.0
datatools^0.4.0-nullsafety.00.4.0-nullsafety.00.8.0
equatable^2.0.0-nullsafety.02.0.32.0.3
geocore^0.4.0-nullsafety.00.4.1-nullsafety.00.7.2
meta^1.3.0-nullsafety.61.7.01.7.0
synchronized^3.0.0-nullsafety.13.0.03.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
intl-0.17.00.17.0
path-1.8.11.8.1
source_span-1.8.21.8.2
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.4.0-nullsafety.0` on attributes does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions attributes to update the constraint.

The constraint `^0.4.0-nullsafety.0` on datatools does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions datatools to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • geodata that depends on:
  • datatools that depends on:
  • http_parser that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.4, Dart 2.15.1.

2
likes
80
pub points
0%
popularity

Publisher

shield icon for verified publishersnavibyte.com

A geospatial client reading OGC API and other geospatial data sources.

Homepage
Repository (GitHub)
View/report issues

License

BSD-3-Clause (LICENSE)

Dependencies

attributes, datatools, equatable, geocore, meta, synchronized

More

Packages that depend on geodata