geo_firestore_flutter 0.0.5
geo_firestore_flutter: ^0.0.5 copied to clipboard

Flutter Android iOS macOS web

GeoFirestore for Flutter to do location based queries with Firestore

3
likes
90 / 110
pub points
63 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 20 API elements (55.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:geo_firestore_flutter/geo_firestore_flutter.dart that imports:
  • package:geo_firestore_flutter/src/geo_utils.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/geo_firestore_flutter.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^0.16.00.16.0+11.0.0
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
cloud_firestore_platform_interface-3.0.24.0.0
cloud_firestore_web-0.3.0+21.0.0
collection-1.15.0-nullsafety.31.15.0
firebase_core-0.7.01.0.0
firebase_core_platform_interface-3.0.14.0.0
firebase_core_web-0.2.1+31.0.0
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
js-0.6.20.6.3
matcher-0.12.90.12.10
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
plugin_platform_interface-1.0.32.0.0
quiver-2.1.53.0.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.16.0` on cloud_firestore does not support the stable version `1.0.0`, that was published 3 days ago.

When cloud_firestore is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

3
likes
90
pub points
63%
popularity

Publisher

percula.dev

GeoFirestore for Flutter to do location based queries with Firestore

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cloud_firestore, flutter

More

Packages that depend on geo_firestore_flutter