gcloud 0.7.3
gcloud: ^0.7.3 copied to clipboard

High level idiomatic Dart API for Google Cloud Storage, Pub-Sub and Datastore.

23
likes
80 / 110
pub points
90 %
popularity

We analyzed this package on Apr 23, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 277 out of 417 API elements (66.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:gcloud/db.dart that imports:
  • dart:mirrors
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: 'onError' is deprecated and shouldn't be used. Use runZonedGuarded instead.

lib/service_scope.dart:213:25

    ╷
213 │     }, zoneValues: map, onError: onError);
    │                         ^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/service_scope.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/datastore_impl.dart:398:22

    ╷
398 │       var entities = List<datastore.Entity>(apiKeys.length);
    │                      ^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/datastore_impl.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
_discoveryapis_commons>=0.1.6+1 <0.3.00.2.11.0.0
googleapis>=0.50.2 <1.0.00.56.12.0.0
http>=0.11.0 <0.13.00.12.20.13.1
meta^1.0.21.3.01.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=0.1.6+1 <0.3.0` on _discoveryapis_commons does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions _discoveryapis_commons to update the constraint.

The constraint `>=0.50.2 <1.0.0` on googleapis does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions googleapis to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.