gcloud 0.7.3

Dart native

High level idiomatic Dart API for Google Cloud Storage, Pub-Sub and Datastore.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  gcloud: ^0.7.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:gcloud/common.dart';
import 'package:gcloud/datastore.dart';
import 'package:gcloud/db.dart';
import 'package:gcloud/db/metamodel.dart';
import 'package:gcloud/http.dart';
import 'package:gcloud/pubsub.dart';
import 'package:gcloud/service_scope.dart';
import 'package:gcloud/storage.dart';