gallery_previewer 0.0.2+1
gallery_previewer: ^0.0.2+1 copied to clipboard

A new Flutter package project.

2
likes
70 / 110
pub points
69 %
popularity

We analyzed this package on Apr 10, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 37 API elements (8.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:gallery_previewer/gallery_previewer.dart that imports:
  • package:gallery_previewer/src/gallery_view_item.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_web.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^3.0.03.0.03.0.0
flutterflutter0.0.00.0.0
flutter_pagewise^1.2.31.2.32.0.1
photo_manager^1.0.61.1.11.1.1
photo_view^0.11.10.11.10.11.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.23.1.2
async-2.5.02.5.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.0.13.0.1
http-0.13.10.13.1
http_parser-4.0.04.0.0
image-3.0.23.0.2
meta-1.3.01.3.0
octo_image-1.0.0+11.0.0+1
path-1.8.01.8.0
path_provider-2.0.12.0.1
path_provider_linux-2.0.02.0.0
path_provider_macos-2.0.02.0.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.02.0.0
pedantic-1.11.01.11.0
petitparser-4.1.04.1.0
platform-3.0.03.0.0
plugin_platform_interface-2.0.02.0.0
process-4.2.14.2.1
rxdart-0.26.00.26.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+32.0.0+3
sqflite_common-2.0.0+22.0.0+2
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.43.0.4
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.2.00.2.0
xml-5.1.05.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.2.3` on flutter_pagewise does not support the stable version `2.0.0`, that was published 7 days ago.

When flutter_pagewise is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_pagewise to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.